Service update: AWS outage impacting TEG platform

Minor incident Exchange
2025-10-20 10:38 BST · 1 hour, 56 minutes

Updates

Resolved

Dear Member,

This morning, the TEG platform was impacted by a major Amazon Web Services (AWS) outage, which caused widespread internet disruptions globally, including our login and authentication services.

Current status

All services, including phone lines and SMS authentication, are now fully operational.

We will continue to monitor the situation and provide updates if anything changes.

Support availability

You can now reach us via:
Phone
Live chat
Email
Submit a ticket

Thank you for your patience and understanding during this disruption.

October 20, 2025 · 12:08 BST
Monitoring

Dear member.

This morning, the TEG platform was impacted by a major Amazon Web Services (AWS) outage, which caused widespread disruptions globally and affected login and authentication services.

Current Status

All Services have now been restored, but we will continue to monitor the situation.

Support Availability

Please note our phone lines are currently affected by the outage, so please do not call us.

We’re still available to assist you via:
Live chat
Email
Submit a ticket

How to stay updated

The easiest way to stay informed is to subscribe to our operational status updates.
This will ensure you’re notified immediately of any progress updates or as soon as the issue is resolved.

We apologise for any inconvenience and appreciate your patience while we monitor the situation and support you through this disruption.

Kind regards,

TEG

October 20, 2025 · 10:38 BST

← Back