Invoice Creation

Minor incident Mobile app
2026-09-10 12:42 BST · 1 hour, 9 minutes

Updates

Resolved

Hello

Further to our earlier update, we have now implemented a fix for the invoice creation issue and seeing functionality being restored, please allow some time before trying again.

If you continue to experience problems after trying to create the invoice again, please let us know

Thank you for your patience throughout.

Kind regards,

September 10, 2026 · 13:50 BST
Monitoring

Hello,

Thank you for your patience.

We are aware of the issue impacting invoice creation and our technical team is continuing to look into this.

We will advise as soon as this is resolved.

September 10, 2026 · 13:15 BST
Investigating

Hello,

We have identified an issue with invoice creation and are currently working to resolve this.

We will ensure that we update you as soon as possible.

Thank you for your understanding.

September 10, 2026 · 12:42 BST

← Back