Invoice and POD issue
Minor incident
SmartPay (Accounts Receivable)
2026-08-10 10:10 BST
· 1 hour, 45 minutes
Updates
Investigating
August 10, 2026 · 11:33 BST
Hello,
Thank you for your patience we are looking into this issue and will have an update as soon as possible.
We will advise as soon as all is resolved.
Investigating
August 10, 2026 · 11:10 BST
Hello,
Thank you for your patience we are looking into this issue and will have an update as soon as possible.
We will advise as soon as all is resolved.
Investigating
August 10, 2026 · 10:41 BST
Hello,
Thank you for your patience we are looking into this issue and will have an update as soon as possible.
We will advise as soon as all is resolved.
Issue
August 10, 2026 · 10:10 BST
Hello,
Thank you for your email.
We have identified an issue with invoicing and saving PODs and are currently working to resolve this.
We will ensure that we update you as soon as possible.
Thank you for your understanding.
← Back
Transport Exchange Group Status