Investigating an issue effecting the Platform

Major incident Exchange
2026-04-20 08:39 BST · 2 hours, 45 minutes

Updates

Resolved

Hello,

Thank you for your patience while we worked to resolve the issue regarding the platform errors.

We are pleased to confirm that the matter has now been successfully resolved. Please accept our apologies for any inconvenience caused, and thank you for your understanding and cooperation during this time.

If you have any further questions or require additional support, please do not hesitate to contact us.

Thank you once again for your patience and continued support.

Wishing you a pleasant day.

April 20, 2026 · 11:23 BST
Monitoring

Hello,

Thank you for your patience while we looked into this.

We have identified the issue and are working to resolve it as soon as possible.

We will provide a further update once everything has been fully resolved.

April 20, 2026 · 11:20 BST
Investigating

Hello,

Thank you for your patience..

We are currently looking into the issue and will provide a resolution as soon as possible.

We will keep you updated and notify you once this has been fully resolved.

April 20, 2026 · 10:47 BST
Investigating

Hello,

Thank you for your patience while we investigated this.

We are still looking into the issue and will provide a resolution as soon as possible.

We will keep you updated and notify you once we have more information.

April 20, 2026 · 10:15 BST
Investigating

Hello,

Thank you for your patience while we investigated this.

We are currently looking into the issue and will provide a resolution as soon as possible.

We will keep you updated and notify you once this has been fully resolved.

April 20, 2026 · 09:39 BST
Investigating

Hello

We are currently looking into a issue effecting the platform, and this will be resolved as soon as possible.

Thank you for your patience

April 20, 2026 · 08:39 BST

← Back