SmartPay

Minor incident Finance Manager (Account Receivable) Finance Manager (Accounts Payable)
2025-11-26 16:57 GMT · 3 hours, 36 minutes

Updates

Resolved

Hello,

We appreciate your patience as we worked to resolve the issue concerning SmartPay.

We are pleased to inform you that the matter has now been successfully resolved. We apologize for any inconvenience this may have caused and are grateful for your understanding and cooperation during this time.

All payments will be processed and visible on your TEG Wallet. Should you have any further questions or concerns, please do not hesitate to contact us.

Thank you once again for your patience and continued support.

Wishing you a pleasant evening.

November 26, 2025 · 20:32 GMT
Update

Hello,

Thank you for your patience while we work to resolve this issue.

Payments are still being processed through SmartPay, however, there is still an error with locating these in the TEG Wallet which we are actively working to resolve.

We will update you again shortly.

November 26, 2025 · 18:35 GMT
Investigating

Hello,

Thank you for your patience whilst we looked into this.

We have identified the issue and this will be resolved as soon as possible.

We will advise as soon as all is resolved.

November 26, 2025 · 18:01 GMT
Investigating

Hello,

Thank you for your patience whilst we looked into this.

We have identified the issue and this will be resolved as soon as possible.

We will advise as soon as all is resolved.

November 26, 2025 · 17:29 GMT
Investigating

Hello,

Thank you for your email.

We have identified an issue with SmartPay and are currently working to resolve this.

We will ensure that we update you as soon as possible.

Thank you for your understanding.

November 26, 2025 · 16:57 GMT

← Back