Bad Gateway
Major incident
Exchange
2025-08-13 13:52 BST
· 34 minutes
Updates
Resolved
August 13, 2025 · 14:24 BST
Hello,
We appreciate your patience as we worked to resolve the issue concerning logging into the Exchange and mobile apps.
We are pleased to inform you that the matter has now been successfully resolved. We apologize for any inconvenience this may have caused and are grateful for your understanding and cooperation during this time.
Should you have any further questions or concerns, please do not hesitate to contact us.
Thank you once again for your patience and continued support.
Wishing you a pleasant day.
Investigating
August 13, 2025 · 13:52 BST
Hello,
I hope this email finds you well.
We have identified an issue with logging into the Exchange and are currently working to resolve this.
We will ensure that we update you as soon as possible.
Thank you for your understanding.
← Back