Platform issues
Minor incident
Exchange
2024-10-09 16:13 BST
· 22 minutes
Updates
Resolved
October 9, 2024 · 16:33 BST
Good afternoon,
Thank you for your patience whilst we investigated the issue with platform.
I am pleased to confirm that this has been resolved.
We would advise that you log out of the desktop, and log back in for any updates to pull through.
If you are still experiencing issues, please email [email protected].
Kind regards,
TEG Team
Issue
October 9, 2024 · 16:13 BST
Good afternoon,
We have identified an issue with the platform and are currently working to resolve this.
We will ensure that we update you as soon as possible.
Thank you for your understanding.
Kind regards,
TEG team
← Back