Unable to login

Minor incident Exchange
2024-05-15 06:28 BST · 17 minutes

Updates

Resolved

Good morning,

Thank you for your patience.

I am pleased to confirm that the issue with not being able to log in has now been resolved.

Kind regards
TEG Support Team

May 15, 2024 · 06:41 BST
Issue

Good morning,

We have been made aware of an issue where members are reporting that they are not able to log in to the Exchange.

Our Technical Support Team are working hard to resolve the issue.

We will update you as soon as possible, thank you for your patience.

Kind regards
TEG Support Team

May 15, 2024 · 06:28 BST

← Back