Accounting on mobile app

Minor incident Accounting
2024-04-30 09:03 BST · 17 minutes

Updates

Resolved

Good Morning,

Thank you for your patience.

The issue with the accounting on the mobile app has now been resolved.

Kind regards,
TEG Support Team

April 30, 2024 · 09:17 BST
Issue

Good Morning,

We have identified an issue with accounting on the mobile app.

Our technical support team is currently investigating.

We will provide an update in 30 minutes.

Kind regards,
TEG Support Team

April 30, 2024 · 09:03 BST

← Back