Hx log in issues

Minor incident Exchange
2023-12-07 12:11 BST · 1 hour, 34 minutes

Updates

Resolved

Dear members,

We have received confirmation from our Technical Support team that the issue has now been resolved.

If you do experience any further issues logging in, please reset your password.

Kind regards,

TEG Support Team

December 7, 2023 · 13:44 BST
Investigating

Dear member,

Thank you for your continued patience.

Our Technical Support team are still working to fix the log in issue.

We will update again in 30 minutes.

Kind regards,

TEG Support Team.

December 7, 2023 · 12:42 BST
Issue

Dear member,

We have identified an issue with logging into HX.

We will provide an update within 30 minutes.

Kind regards,

TEG Support Team.

December 7, 2023 · 12:11 BST

← Back