Connection Issue on Website

Minor incident Exchange
2023-10-19 12:09 BST · 15 minutes

Updates

Resolved

Dear Member,

The issue affecting some of our members while using the desktop version of the Exchange has now been rectified.

Thank you for your patience.

Kind regards,
TEG Support Team

October 19, 2023 · 12:24 BST
Issue

Dear Member,

We have identified an issue that is affecting some of our members while using the desktop version of the Exchange and may be experiencing connection error messages.

Our technical team is working hard to rectify the issue, we will send an update in 30 minutes.

Kind regards,
TEG Support Team

October 19, 2023 · 12:09 BST

← Back