Intermitting Issues with the Exchange Website

Major incident Exchange
2023-09-08 12:49 BST · 31 minutes

Updates

Resolved

Hello.

I am pleased to confirm that the issue with the Exchange website has now been resolved.

You may need to log out and log back in for the updates to pull through.

Thank you for your patience.

September 8, 2023 · 13:18 BST
Issue

Hello,

We have been made aware of an issue that is affecting the Exchange.

The issue is intermittent, we’re working hard to resolve this as soon as possible.

We will send an update in the next 30 minutes.

Thank you for your patience.

September 8, 2023 · 12:49 BST

← Back