Issue with Mobile Apps and Website

Major incident Exchange
2023-07-17 14:48 BST · 2 hours, 17 minutes

Updates

Resolved

Good evening.  

We are pleased to confirm that the issue with the Exchange website and mobile apps has now been resolved.  

You may need to log out and log back in for the updates to pull through.

We appreciate the time it has taken to resolve.

July 17, 2023 · 17:05 BST
Resolved

Good evening.  

We are pleased to confirm that the issue with the Exchange website and mobile apps has now been resolved.  

You may need to log out and log back in for the updates to pull through.

We appreciate the time it has taken to resolve.

July 17, 2023 · 17:05 BST
Investigating

Good evening.

We are pleased to confirm that the issue with the Exchange website and mobile apps has now been resolved.

You may need to log out and log back in for the updates to pull through.

We appreciate your time this has taken to resolve.

July 17, 2023 · 17:01 BST
Investigating

Hello

Thank you for your continued patience.

We are still investigating the issue with the website and apps.

We will keep you updated.

Kind regards
TEG Support Team

July 17, 2023 · 16:34 BST
Investigating

Hello.

Thank you for your patience.

I can confirm that the issue with the Exchange website is now working as expected, however we are still experiencing issues with the mobile apps.

We will update again shortly.

July 17, 2023 · 15:26 BST
Issue

Hello.

We have been made aware of an issue that is affecting the mobile apps and website.

We are working hard to resolve this as soon as we can.

We will update you once this has been resolved.

July 17, 2023 · 14:48 BST

← Back