Not able to log into app or desktop

Minor incident Exchange
2023-07-13 17:31 BST · 3 hours

Updates

Resolved

Good Evening.

I am pleased to confirm that the issue with not being able to login with the app or website has now been resolved.

Thank you for your patience.

July 13, 2023 · 20:31 BST
Issue

Good afternoon,

We have been made aware members are not able to log into the Exchange.

We are aware of the incident and are looking into it.

Kind regards

July 13, 2023 · 17:31 BST

← Back