Connection Issue on Website

Minor incident Exchange
2023-04-27 11:48 BST · 33 minutes

Updates

Resolved

We are pleased to confirm that the issue experienced earlier has now been resolved.

Thank you for your patience during this time.

April 27, 2023 · 12:21 BST
Issue

We are aware of an issue affecting the desktop where we are having connection issues or slow loading times.

We are looking into this as a priority and we will provide an update within 30 minutes.

Thank you.

April 27, 2023 · 11:48 BST

← Back