Issue with Mobile Apps

Minor incident Exchange
2023-03-29 11:40 BST · 1 hour, 13 minutes

Updates

Resolved

I am pleased to confirm that the mobile issue has now been resolved.

Thank you for your patience.

Have a lovely day.

March 29, 2023 · 12:54 BST
Investigating

Thank you for your patience whilst we are looking into the issue.

We are looking into this as a priority and will provide an update in 30 minutes.

Thank you.

March 29, 2023 · 12:17 BST
Issue

We are aware of an issue affecting our mobile apps where the server unreachable is showing.

We are looking into this as a priority and we will provide an update within 30 minutes.

Thank you.

March 29, 2023 · 11:42 BST

← Back