Error 404 / 502

Minor incident Exchange
2023-03-13 09:33 BST · 2 minutes

Updates

Resolved

We are pleased to confirm that this is now resolved.

Thank you again for your patience whilst we reviewed this.

Have a lovely day.

March 13, 2023 · 09:35 BST
Issue

We are aware of an issue experienced this morning with the above error codes.

This has affected the Exchange and Mobile apps.

We are reviewing as a priority.

March 13, 2023 · 09:34 BST

← Back