Mobile App Issue

Minor incident Exchange
2023-03-10 12:34 BST · 17 minutes

Updates

Resolved

I am pleased to confirm that the issue with our mobile apps is now resolved.

Thank you again for your patience during this time.

Have a lovely day.

March 10, 2023 · 12:52 BST
Issue

We are aware of an issue with our mobile app showing bad gateway or server unreachable.

This is being looked into as a priority.

We will update you within the next 30mins, thank you for your patience.

March 10, 2023 · 12:35 BST

← Back