Post Load Form

Minor incident Exchange
2023-03-08 12:22 BST · 1 hour, 1 minute

Updates

Resolved

Thank you for your patience whilst we looked into the issue with our booking form. I am pleased to confirm that we have now resolved this.

Please Ctrl F5 to refresh your screen and log back into your account.

Please accept our apologies for any inconvenience caused.

March 8, 2023 · 13:24 BST
Issue

We are aware of an issue with the new load booking form.

We are investigating this as a priority and will update within the next 30mins.

March 8, 2023 · 12:23 BST

← Back