Map Distance

Minor incident Exchange
2023-02-20 10:23 BST · 29 minutes

Updates

Resolved

I am pleased to confirm that the issue with the map distance has been resolved.

Please refresh your app/desktop to pull the update through.

Thank you for your patience.

February 20, 2023 · 10:53 BST
Issue

We are aware of an issue where are maps are not showing the distance/miles.

We are working on this as a priority and will provide an update in the next 30 minutes.

February 20, 2023 · 10:24 BST

← Back