Mobile App

Minor incident Notification Issues Exchange Finance Manager (Account Receivable) Finance Manager (Accounts Payable) Integrations Accounting
2023-02-20 08:39 BST · 40 minutes

Updates

Resolved

We are pleased to confirm that this has now been resolved.

Thank you for your patience.

February 20, 2023 · 09:20 BST
Issue

We have identified a technical issue on our mobile application. We are working on resolving this fault as a matter of urgency and will keep you updated as to the progress of the resolve.
Thank you for your understanding.
Transport Exchange Group

February 20, 2023 · 08:41 BST

← Back