Exchange Issue

Major incident Exchange
2023-02-15 13:08 BST · 1 hour, 44 minutes

Updates

Resolved

Hello,

I am pleased to confirm that this is now resolved.

Thank you for your support during this time.

February 15, 2023 · 14:53 BST
Escalate

We are aware that this is now affecting the Platform and our Mobile Apps.

We are investigating this as a priority and will update within the next hour.

Thank you for your continued patience.

February 15, 2023 · 14:18 BST
Investigating

Thank you for your patience.

We are still investigating this as a priority and will update you within the next hour.

February 15, 2023 · 14:05 BST
Issue

We are currently experiencing an issue with our Drivers and Fleet apps. We are working on this as a priority and will update within an hour.

Thank you.

February 15, 2023 · 13:09 BST

← Back