Exchange Issue

Major incident Exchange
2023-02-13 11:04 BST · 51 minutes

Updates

Resolved

I am pleased to confirm that the issue has now been resolved.

Thank you for your patience.

February 13, 2023 · 11:55 BST
Escalate

Thank you for your patience.

We are aware that this is affecting the Exchange and are working on this as a priority.

We will update within the next hour.

Thank you.

February 13, 2023 · 11:40 BST
Issue

We are currently aware of an error message appearing on our Mobile App.

This is being looked into as a matter of urgency and we will update within the next hour.

Thank you.

February 13, 2023 · 11:05 BST

← Back