Mobile App Issue

Minor incident Exchange
2023-01-26 15:43 BST · 1 hour, 21 minutes

Updates

Resolved

Thank you for your patience whilst we looked into the issues with the mobile app.

I am pleased to confirm that this has now been resolved.

If you experience any further issues, please reach out to our Support Team.

Have a lovely evening.

January 26, 2023 · 17:05 BST
Issue

We are aware of an issue with the mobile app. We are working hard to resolve this and will update within an hour.

January 26, 2023 · 15:46 BST

← Back